User Tools

Site Tools


Sidebar

Top
Seminar
Courses
Textbooks
Documents
Downloads (-2016)
Downloads (2016-)
Weblog
RSS aggregates
Discussions
Archives


EMBL BioImage Data Analysis

EuBIAS

NEUBIAS

—- Contact
CMCI Alumni
ALMF
EMBL Heidelberg
EMBL Intranet


Popularity Ranking


Timeline of @cmci_

cmci_ avatar

RT @empleo_mid: Puesto: 1 PhD student position available for "Image analysis of cardiac development in the mouse" - CNIC https://t.co/0AfJ8
About 14 hours, 22 mins ago by: Kota Miura (@cmci_)

cmci_ avatar

RT @CanonMedicalEDI: Five #vacancies currently open: Image Analysis Scientist, Software Engineer (various) & IT Administrator. Rewarding #H…
About 1 day, 15 hours ago by: Kota Miura (@cmci_)

cmci_ avatar

@haesleinhuepf @ReynaudEmmanuel @BioImagingUK @BBSRC @NEUBIAS_COST ... and fun!
About 1 day, 15 hours ago by: Kota Miura (@cmci_)

cmci_ avatar

RT @thewtex: @cmci_ @ProjectJupyter @UCBIDS @stefanvdwalt @cziscience @thefreemanlab @ctrueden @FijiSc @cmci_ sorry about the quality. Here…
About 1 day, 16 hours ago by: Kota Miura (@cmci_)

cmci_ avatar

@thewtex @ProjectJupyter @UCBIDS @stefanvdwalt @cziscience @thefreemanlab @ctrueden @FijiSc thanks!
About 1 day, 16 hours ago by: Kota Miura (@cmci_)

cmci_ avatar

@thewtex @ProjectJupyter @UCBIDS @stefanvdwalt @cziscience @thefreemanlab @ctrueden @FijiSc great! do you have an y… https://t.co/Xnyd9VhAip
About 1 day, 16 hours ago by: Kota Miura (@cmci_)
downloads:hyperstackexporttoimaris

Export Hyperstack to Imaris

Author

Kota Miura
Centre for Molecular and Cellular Imaging (CMCI)
EMBL Heidelberg
miura at embl dot de
Tel: +49 6221 387 404

History

  • 10-08-06 First Version.

Source

Released under the GNU General Public License.

Requires

ImageJ ver 1.37j or higher (ImageJ, upgrade page).

A commercial software Imaris (Bitplane) ver 7.0.0 and its optional module ImarisXT.

Installation

You need to install several files.

  1. Download ImarisPlugin3_.jar and place the file in the plugin folder of ImageJ.
  2. Download jacob-1.15-M3.zip from JACOB site (JACOB bridge is a module that bridges between Java and Windows application). Unzip the file and then
    • place jacob-1.15-M3-x86.dll (if your machine is 64-bit, then jacob-1.15-M3-x64.dll) in a directory where system path is set in your machine. In my case, I copied it under C:\Sun\SDK\jdk\jre\bin.
    • place jacob.jar under C:\Sun\SDK\jdk\jre\lib\ext, where java path is set.

Description

Exports multidimensional stack opened in ImageJ directly to Imaris, so that 3D time series with multiple channels could be visualized and inspected using useful interface of Imaris. It works with 8-bit and 16-bit stacks. 32-bit stack exporting should work but not tested.

Following types of stacks could be exported:

  • Z stack
  • cz stack (up to 4 channels)
  • RGB - Z stack
    • each color channel will be treated as a single channel)
  • ZT stack
  • CZT stack
  • RGB - ZT stack
    • each color channel will be treated as a single channel)

In case of CZ, ZT, CZT, RGB-ZT stacks, stack should be already be converted to Hyperstack (Image → Stack → Stack to HyperStack). You should also be sure that dimensional sizes in [Image → Image Properties] are correctly set, since plugin reads dimensional information from this.

Work Flow

  • Open a hyperstack in ImageJ.
  • Do [Plugins → Imaris → Hyperstack Exporter…]. “Imaris Interface” window appears.
  • Click “Start Imaris”. Imaris application starts up.
  • In the panel “Stack Export to Imaris”, click appropriate button that matches with the dimension of your stack. Then wait for the exporting to finish.
  • You could close this “Imaris Interface” window. Although there is check button saying “Exit Imaris when closing this dialog”, Imaris survives even when ImageJ is terminated.

Development

Acknowledgement

This plugin was written on top of example java application “HelloImaris.java” written by Volker Baecker, which is available in the Bitplane website.

downloads/hyperstackexporttoimaris.txt · Last modified: 2016/05/24 05:46 (external edit)