User Tools

Site Tools


Sidebar

Top
Seminar
Courses
Textbooks
Documents
Downloads (-2016)
Downloads (2016-)
Weblog
RSS aggregates
Discussions
Archives


EMBL BioImage Data Analysis

EuBIAS

NEUBIAS

—- Contact
CMCI Alumni
ALMF
EMBL Heidelberg
EMBL Intranet


Popularity Ranking


Timeline of @cmci_

cmci_ avatar

RT @biomicugm: Topics: Biostatistics, computational evolutionary biology, computational genomics and proteomics, graph models, image analys…
About 4 days, 16 hours ago by: Kota Miura (@cmci_)

cmci_ avatar

RT @JustinMCrocker: We are looking for an interdisciplinary EIPOD postdoc to join our group @EMBL! Potential projects with @Eileen_Furlong,…
About 4 days, 16 hours ago by: Kota Miura (@cmci_)

cmci_ avatar

RT @BioImagingUK: This maybe of interest to the @NEUBIAS_COST @openmicroscopy communities #imageAnalysis #imagingScientist https://t.co/I5
About 4 days, 16 hours ago by: Kota Miura (@cmci_)

cmci_ avatar

RT @BioImagingUK: Software developer position on large image data analysis - working closely with the lab of @bayraktar_lab @sangerinstitut…
About 1 week, 2 days ago by: Kota Miura (@cmci_)

cmci_ avatar

RT @AssafZaritsky: Modeling the interplay of lamellipodial motion and the intercellular actomyosin cable during epithelial wound healing h…
About 1 week, 2 days ago by: Kota Miura (@cmci_)

cmci_ avatar

RT @jytinevez: @florianjug says be careful when using #CARE for intensity based quantification; CARE restoration is like a non linear trans…
About 1 week, 4 days ago by: Kota Miura (@cmci_)
downloads:spindlefanalyzer
Measurment of Microtubule Associated Protein Flux

Spindle Microtubule Frap / Flip Analyzer

Author

Kota Miura
Centre for Molecular and Cellualr Imaging (CMCI), EMBL Heidelberg
miura at embl dot de Tel: +49 6221 387 404

History

08-08-12? First release

Source

Released under the GNU General Public License.

Installation

Download K_YprojectionV2.ijm to a place where you can access easily. Install the macro by [Plugins→Macros→Install…].

Requires

ImageJ ver 1.34j or higher (ImageJ, upgrade page).

Description

The specific purpose of this macro was to follow the intensity dynamics occurring within double labeled microtubule spindle. Intensity changes that are occurring at stable position is easy, but this macro enables measurement of intensity changes that accompanies movement of the bleached/activated position. For the actual application, please refer to the fillowing paper:

Poleward transport of Eg5 by dynein-dynactin in Xenopus laevis egg extract spindles.
Uteng, M., Hentrich, C., Miura, K., Bieling, P. & Surrey, T.
J Cell Biol. 2008 Aug 25;182(4):715-26. Epub 2008 Aug 18.PubMed


Fig.1 Red Channlel/Tubulin
Fig.2 Tubulin signal converted to mask
Fig.3 Green Channlel/MAP

Using a pair of two-channel image stacks, this macro measures dynamics of integrated intensity profile along x-axis of a channel masked by a mask created using the other channel. For example, we take red channle and green channel images. In red channle (Fig. 1), tubulin is labled and in the green channel (Fig. 3), certain microtubule-associated protein is labeled. The program first creates a mask (black and white image, Fig. 2) from tubulin R-channel that specifies the area of the spindle. Then this specified area is measured for the integrated intensity profile (projected in y-axis, and measured along x-axis). Same procedure is done for the all frames within the stacks automatically. Profile data will be printed out in the Results window as a table. Another functionincluded in the macro will let the user to plot the multiple profiles in a graph to evaluate the measurements. Results could also be exported and examined using other software such as Excel.?

Other papers using this macro

- Fu, J., Bian, M., Xin, G., Deng, Z., Luo, J., Guo, X., Chen, H., Wang, Y., Jiang, Q., Zhang, C., 2015. TPX2 phosphorylation maintains metaphase spindle length by regulating microtubule flux. J. Cell Biol. 210, 373–83.

Work Flow

Fig. 4
Fig. 5 Results window

1. Measurment of Profile Dynamics

1.1. Install the macro by [Plugins → Macros → Install…].

1.2. Open two stacks, one containing a movie for masking (c.f. Tubulin) and other for measurements (c.f. MAP).?Threshold the tubulin window by [Image → Adjust → Threshold…] (do not actully convert the image to black and white, meaning don't click the apply button in the threshold panel) and by this determine a lower threshold value that highlights the tubulin successfully. This value will be used in the following step. One could also store the lower threshold value in memory by [Plugins → Macros → get Threshold Lower] while the thresholded area is highlighted.

1.3. Do [Plugins → Macros –> Y projection profile two channels]. A dialogue window pops up (Fig 4.). Choose appropriate window names using the pull-down menu, and also input the threshold value determined in 1.2. Uncheck “Noise spot Removal”. Then click “OK”. “Noise spot Removal” works when only a single connected masked area (largest) is expected in the tubulin image stack (and this normally is, since there is only one spindle). Then you could check this option to remove small peripheral masks that are unwantedly included in the mask.

1.4.? Two new image stacks will be created, one called “mask.tif” nad the other called “measurement_stack.tif”. The formaer is the segmented image of the tubulin channel for the masking, and the second stack is the one that was used for the actual profile measurements. Results winodw either appears or refreshes, and will list all the values in a table (Fig. 5).

Column header explanation:

  • “x”: x-coordinate within the image.
  • “int_f1”: integrated intensity of the masked green channel in the frame 1 at position x.
  • “Ycount_f1”: the number of pixels that was used for the measurement for position x.

These results could be saved as a .xls file (excel format) by [File → Save As…] from the menu bar of the results window.
?
2. Graphing the Profiles

Fig. 6 Plotter Dialogue

2.1. While the above Results window is still opened (plotting loads data from Results window), do [Plugins → Macros → Profile Plotter]. If Results window is absent and you know that you have saved the file somewhere, you can re-open it by [File → Import → Results]. Data will be loaded into the Results window. Then a dialogue window pops up (Fig.6).

There are two options. One is 'Plot Increments', which defines the frame-wise increments for the plotting. This is useful when there are too many time points that the plotting will cover the graph all over and cannot resolve each single curve at different time points, and that you want to plot only part of the results. You could increase the increment and draw a graph with less profiles. If there are only 10 or so frames, increment could be 1 and plot everything.

The second option is to avoid plotting the first frame profile, since in many cases the first frame in fluorescence image sequence tends to be dark and cannot be used for the measurement.

After setting these two options, click “OK”.

2.2. Two graphs will then appear which look like below.

Fig. 7 Profile Integrated Intensity



The first graph (Fig. 7) shows integrated intensity (sum of pixel values) vs x-position. Each color corresponds to different time point, the legend of which is printed in the Log window.

Fig.8 Y-width of the mask (spindle)



Second graph (Fig. 8) plots the height of mask in each x-position. If you divide the y value in the first graph by the y values in the second graph, you will get the average intensity for each position at each time point.

3. Optional function: realignment of spindle

3.1. Realign spindle when spindle is tilted against x-axis. For example, here is a spindle that is tilted (Fig. 9).

Fig. 9 Tilted spindle, and drawing a line ROI between spindle poles (right, yellow line)
Fig. 10 Dialogue for frame rotation

To realign these spindles, draw a Line ROI from one spindle pole to the other pole in the tubulin channel like the example above. Line ROI should start from left side of the spindle (this is because of calculation purpose, starting point should always be left). Then do [Plugins → Macros → Rotate Sync 2ch to Horizontal]. A dialogue wiindow pops up (Fig. 10). Choose the appropriate windows. Other options do not affect the rotation operation. Then click OK. After the processing, the resulted windows should look like below.

Fig. 11 After Rotatation

?

downloads/spindlefanalyzer.txt · Last modified: 2016/05/25 02:26 by kota